Peu commune

QUIC

protocole réseau

QUIC

Carte Peu commune · n° 116459

QUIC est un protocole de transport fiable et sécurisé, en mode connecté, mis au point en 2012 par Jim Roskind (en), employé chez Google. Il est repris par l'IETF en 2015 dans le but de le normaliser par les RFC 8999, RFC 9000, RFC 9001 et RFC 9002 et le rendre ainsi utilisable par n'importe quel protocole de la couche application. Les acteurs impliqués veulent que QUIC soit plus que « HTTP sur UDP », là où Google désire prioriser le web. Initialement QUIC signifie « Quick UDP Internet Connections », mais l'IETF ne le considère pas comme un acronyme et il n'y en a aucune trace dans les RFC. Le protocole est destiné à remplacer TCP (HTTP/3) dont il reprend la plus grande partie des fonctionnalités comme la réémission des paquets perdus et le contrôle de congestion, ce qui lui vaut le surnom de TCP/2. QUIC ajoute de nouvelles fonctionnalités telles qu'une réémission des paquets perdus non bloquante, une gestion de la couche transport par l'application et non par le noyau, un chiffrement TLS...

Lire sur Wikipédia · Image xchiamiov, CC BY 2.0

Ouvre des boosters, collectionne des cartes et échange-les. Gratuit.

Jouer gratuitement
QUIC – carte Wikipédia Peu commune | Wikiverse TCG